
























































    
         
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Content w/o Tools" />
  
    <meta name="oid" content="2899870" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=091cc0e6e95b5e61c272f101a1c0ad56" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=091cc0e6e95b5e61c272f101a1c0ad56" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=091cc0e6e95b5e61c272f101a1c0ad56" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=091cc0e6e95b5e61c272f101a1c0ad56" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Creative Loafing Charlotte RSS: Whole Site" href="http://clclt.com/charlotte/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Creative Loafing Charlotte RSS: Music Section" href="http://clclt.com/charlotte/Rss.xml?oid=2124591" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Creative Loafing Charlotte RSS: Features" href="http://clclt.com/charlotte/Rss.xml?oid=2124642" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Creative Loafing Charlotte RSS: Comments on Christian punks MxPx wrestle with doubt &mdash; and greatness" href="http://clclt.com/charlotte/Rss.xml?id=comments&amp;oid=2899870" />
    
  

  
  
    <script src="/foundation/scripts/core-public.js?cb=7eb8783447"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("http:\/\/clclt.com\/charlotte\/Profile", "http:\/\/posting.clclt.com\/charlotte\/MyProfile");
  </script>
  
  
  
  
  
  
  
    
  

  
  
<script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>
              googletag.cmd.push(function() { 
            Foundation = Foundation || {};
            Foundation.Ad = Foundation.Ad || {};
            Foundation.Ad.slots = Foundation.Ad.slots || {};
                Foundation.Ad.slots['div-gpt-ad-charlotte232x90'] = googletag.defineSlot('/88340371/Charlotte232x90', [232, 90], 'div-gpt-ad-charlotte232x90').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlottefixedpencil'] = googletag.defineSlot('/88340371/CharlotteFixedPencil', [980, 45], 'div-gpt-ad-charlottefixedpencil').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlottelargelb'] = googletag.defineSlot('/88340371/CharlotteLargeLB', [970, 90], 'div-gpt-ad-charlottelargelb').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlotteleaderboard'] = googletag.defineSlot('/88340371/CharlotteLeaderboard', [728, 90], 'div-gpt-ad-charlotteleaderboard').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlottehalfpagead'] = googletag.defineSlot('/88340371/CharlotteHalfPageAd', [300, 600], 'div-gpt-ad-charlottehalfpagead').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlottepencil'] = googletag.defineSlot('/88340371/CharlottePencil', [975, 30], 'div-gpt-ad-charlottepencil').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlotterectangle1'] = googletag.defineSlot('/88340371/CharlotteRectangle1', [300, 250], 'div-gpt-ad-charlotterectangle1').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlotterectangle2'] = googletag.defineSlot('/88340371/CharlotteRectangle2', [300, 250], 'div-gpt-ad-charlotterectangle2').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlotterectangle3'] = googletag.defineSlot('/88340371/CharlotteRectangle3', [300, 250], 'div-gpt-ad-charlotterectangle3').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlotteskyscraper1'] = googletag.defineSlot('/88340371/CharlotteSkyscraper1', [160, 600], 'div-gpt-ad-charlotteskyscraper1').addService(googletag.pubads());
                Foundation.Ad.slots['div-gpt-ad-charlotteskyscraper2'] = googletag.defineSlot('/88340371/CharlotteSkyscraper2', [160, 600], 'div-gpt-ad-charlotteskyscraper2').addService(googletag.pubads());
                googletag.pubads().setTargeting('template', ["Content"]);
                googletag.pubads().setTargeting('media', ["screen"]);
                googletag.pubads().setTargeting('section', ["music"]);
                googletag.pubads().setTargeting('category', ["MusicFeatures"]);
                googletag.pubads().setTargeting('oid', ["2899870"]);
                googletag.pubads().setTargeting('tags', ["MxPx All Stars","Mike Herrera","Yuri Ruley and Tom Wisniewski","punk","Christianity","Plans Within Plans","religion"]);
            googletag.pubads().collapseEmptyDivs();
              googletag.enableServices();
                Foundation.Ad.refresh = function (id) {
                  if (id && Foundation.Ad.slots[id]) {
                    googletag.pubads().refresh([Foundation.Ad.slots[id]]);
                  }
                  else {
                    googletag.pubads().refresh();
                  }
                };
                Foundation.Ad.refreshlockout = false;
                if (window.jQuery) {
                  jQuery(document).on("foundation:ad:refresh", function(event) {
                    if (Foundation.Ad.refreshlockout == false) {
                      Foundation.Ad.refreshlockout = true;
                      window.setTimeout(function () {
                        Foundation.Ad.refreshlockout = false;
                      }, 5000);
                      Foundation.Ad.refresh();
                    }
                  });
                }
              }); 
          </script>









<meta name="google-site-verification" content="LNWh0-oEnteML583D9NdXgoT4hGFwwCaqTjIrhe_SMc" />
  <script>
  (function(){
    var ld = document.createElement('script'); ld.type = 'text/javascript';
    ld.async = true; ld.src = 'https://laudd.com/xact/ignite.jsp';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(ld, s);
  })();
</script>
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Christian punks MxPx wrestle with doubt &amp;mdash; and greatness | Features | Creative Loafing Charlotte" />
  <meta name="description" content="Mike Herrera lets his band grow beyond its beginnings" />
  <meta name="keywords" content="MxPx All Stars, Mike Herrera, Yuri Ruley and Tom Wisniewski, punk, Christianity, Plans Within Plans, religion, charlotte concerts, events, charlotte entertainment, charlotte nightlife, theaters in charlotte, best of charlotte, amos&#39; southend, visulite, neighborhood theatre, listings charlotte, jeff hahne, charlotte blogs, music blog, homebrew, live music, Charlotte events, Charlotte restaurants, Charlotte Music, Charlotte concerts, Charlotte news, Charlotte Visual Arts, Charlotte Galleries, Things to do in Charlotte, Charlotte Arts, Charlotte Theater, events in Charlotte, concerts in Charlotte" />
  <title>Christian punks MxPx wrestle with doubt &mdash; and greatness | Features | Creative Loafing Charlotte</title>

  
  
  
    <meta name="author" content="Jordan Lawrence">
  

  
  
  <meta name="news_keywords" content="mxpx all stars, mike herrera, yuri ruley and tom wisniewski, punk, christianity, plans within plans, religion, charlotte concerts, events, charlotte entertainment" />

  
  
  
    <link rel="image_src" href="http://media1.fdncms.com/charlotte/imager/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/u/slideshow/2899871/music_feature2-1_35.jpg" />
    <meta name="thumbnail" content="http://media1.fdncms.com/charlotte/imager/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/u/slideshow/2899871/music_feature2-1_35.jpg" />
  

  
    
      <link rel="canonical" href="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870" />
      
    

    
    
    
  

  
    
      <meta property="og:url" content="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870" />
    
  

  
    <meta property="fb:app_id" content="217890038256200" />
  

  
  <meta property="og:site_name" content="Creative Loafing Charlotte" />
  <meta property="og:title" content="Christian punks MxPx wrestle with doubt &amp;mdash; and greatness" />
 
  
    <meta property="og:image" content="http://media1.fdncms.com/charlotte/imager/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/u/slideshow/2899871/music_feature2-1_35.jpg" />

    
    

    
    

    
      <meta property="og:image:width" content="640" />
      <meta property="og:image:height" content="539" />
    
  

  
  
    <meta property="og:description" content="Mike Herrera lets his band grow beyond its beginnings" />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">2899870</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20161220233625</Attribute>
        <Attribute name="creationdate">20121023144614</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20121025070000</Attribute>
            <Attribute name="releasedate">20121025</Attribute>
            <Attribute name="releaseepoch">1351162800</Attribute>
            <Attribute name="title">Christian punks MxPx wrestle with doubt &#x2014; and greatness</Attribute>
            <Attribute name="author">2548133</Attribute>
            <Attribute name="authorname">Jordan Lawrence</Attribute>
            <Attribute name="authorsortname">Lawrence, Jordan</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"http:\/\/clclt.com\/charlotte\/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness\/Content?oid=2899870"
          },
          "headline": "Christian punks MxPx wrestle with doubt &mdash; and greatness",
          
            "description": "Twenty years ago, MxPx emerged with an infectious attack that helped cement the reputation of a particularly divisive sub-genre &mdash; Christian punk. Positive and punchy, the trio of Washington state high schoolers created easily digestible pop-punk earworms that rarely made preaching points of the band's religious ideals but avoided any language or themes that would offend fellow believers.",
          
          
            "image": {
              "url": "http:\/\/media1.fdncms.com\/charlotte\/imager\/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness\/u\/original\/2899871\/music_feature2-1_35.jpg",
              "width": 600,
              "height": 505,
              "@type": "ImageObject"
            },
          
          "datePublished": "2012-10-25T07:00:00Z",
          "dateModified": "2016-12-20T23:36:25Z",
          
            "author": {
              "name": "Jordan Lawrence",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Creative Loafing Charlotte",
            
              
              
              
              "logo": {
                "url": "http:\/\/clclt.com\/imager\/b\/google-amp-logo\/808579\/7b5b\/adminIcon_ClClt.jpg",
                "width": 400,
                "height": 400,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


  
  

    
    

    
    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="http://media1.fdncms.com/charlotte/imager/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/u/slideshow/2899871/music_feature2-1_35.jpg">

    
    

    

    <meta name="twitter:site" content="">
    <meta name="twitter:title" content="Christian punks MxPx wrestle with doubt &amp;mdash; and greatness">
    <meta name="twitter:description" content="Mike Herrera lets his band grow beyond its beginnings">
  
</head>





  <body id="Content" class="ContentwoTools Iapetus10Zone">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader ContentwoTools " style="display:none">
        
        
          Switch to the <a href="http://m.clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<html>
	<head>
		<title></title>
		<link rel="stylesheet" type="text/css" href="/general/header/headerStyles.css">
	</head>
	<body>
		<div id="headerWrapper">
      
        <div id="socialWrapper">
          Follow us 
          <a href="https://twitter.com/cl_charlotte" target="_blank" title="twitter"><div class="link twitter"></div></a> 
          <a href="https://www.facebook.com/clclt" target="_blank" title="facebook"><div class="link facebook"></div></a> 
          <a href="http://clclt.com/charlotte/Syndication" title="feeds"><div class="link feed"></div></a> 
          <div style="height: 22px; border-left: 1px solid #050608;display:inline-block;vertical-align:middle;margin:-3px 6px 0px 6px;"></div> 
          <a href="http://m.clclt.com">Mobile</a>
        </div>
      
			<div id="loginWrapper">
						
						<div id="CustomHeader" class="GlobalHeader ContentwoTools ">
						
						
							
							<ul data-view="loggedin" style="display:none;">
								<li><strong data-label="username">Username</strong> / </li>
								
								<li><a href="http://posting.clclt.com/charlotte/MyProfile">View Profile</a> / </li>
								<li><a href="http://posting.clclt.com/charlotte/Profile/MySettings">Edit Profile</a> / </li>
								<li><a href="http://clclt.com/charlotte/Logout">Log Out</a></li>
							</ul>

							<ul data-view="loggedout" style="display:none">
								<li><a href="#LogIn">Log in</a> / </li>
								<li><a href="#CreateAccount">Create Account</a></li>
							</ul>
						

					
					
						<script>
							new Foundation.LoginRequiredComponent("CustomHeader");
						</script>
					
					</div>
			
			</div>
      <div id="adWrapper">
        <div class="Ad Leaderboard">
          <!-- /88340371/CharlotteLeaderboard -->
          <div id="div-gpt-ad-charlotteleaderboard" style="" data-slot="/88340371/CharlotteLeaderboard" data-output="asynchronous" data-width="728" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-charlotteleaderboard');
                });
            </script>
          </div>
        </div>
        <div class="Ad Earlug">
          <!-- /88340371/Charlotte232x90 -->
          <div id="div-gpt-ad-charlotte232x90" style="" data-slot="/88340371/Charlotte232x90" data-output="asynchronous" data-width="232" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-charlotte232x90');
                });
            </script>
          </div>
        </div>
        
      </div>
			<div id="logoWrapper">
				<div id="searchWrapper">
						

						  
							
							<form class="prepTextForm" id="searchbox_002407891961455841536:_hyjei94pry" action="http://clclt.com/charlotte/Search">
									<input type="hidden" name="cx" value="002407891961455841536:_hyjei94pry" />
									<input type="hidden" name="cof" value="FORID:9" />
									<input type="text" name="q" size="25" placeholder="Search clclt.com" id="searchInputText" />
									<input type="submit" name="sa" id="searchGoBtn" value="GO" />
							</form>
						
				</div>
				<a href="http://clclt.com" style="width: 500px;height: 132px; display: block; margin: 0 auto;background: none transparent;"></a>
			</div>
			</a>
		</div>
	</body>
</html>
















  <div id="NavigationHorizontal" class="GlobalHeader ContentwoTools ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_news">
          <a href="http://clclt.com/charlotte/news/Section?oid=2124593"  class="subnav_link" id="SNAVL_news">News</a>
        </li>
        
      
        

        

        

        

        <li class="navCurrent" id="NavItem_music">
          <a href="http://clclt.com/charlotte/music/Section?oid=2124591"  class="subnav_link" id="SNAVL_music">Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_arts">
          <a href="http://clclt.com/charlotte/arts/Section?oid=2124589"  class="subnav_link" id="SNAVL_arts">Arts</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_foodanddrink">
          <a href="http://clclt.com/charlotte/food-and-drink/Section?oid=2124590"  class="subnav_link" id="SNAVL_foodanddrink">Food &amp; Drink</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_film">
          <a href="http://clclt.com/charlotte/film/Section?oid=2124592"  class="subnav_link" id="SNAVL_film">Film</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_sexandlove">
          <a href="http://clclt.com/charlotte/sex-and-love/Section?oid=2124609"  class="subnav_link" id="SNAVL_sexandlove">Sex &amp; Love</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Columns">
          <a href="http://clclt.com/charlotte/columns/Section?oid=2988345"  class="subnav_link" id="SNAVL_Columns">Columns</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_blogs">
          <a href="http://clclt.com/blogs/theclog/"  class="subnav_link" id="SNAVL_blogs">Blogs</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_bestofcharlotte">
          <a href="http://clclt.com/charlotte/BestofCharlotte2016/Page"  class="subnav_link" id="SNAVL_bestofcharlotte">Best of Charlotte</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_clevents">
          <a href="http://clclt.com/charlotte/CLEvents/Page"  class="subnav_link" id="SNAVL_clevents">CL Events</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_cldeals">
          <a href="http://clclt.com/charlotte/PeaceoutCLDeals/Page" target="_blank" class="subnav_link" id="SNAVL_cldeals">Ads</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse Music</h3>
            <ul class="subnav_content" id="SNAV_music" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/blogs/vibes/"  title="">Vibes Blog</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://clclt.com/charlotte/EventSearch?eventSection=2362806&feature=CL%20Recommends"  title="">Concert Picks</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?tag=Live%20Reviews"  title="">Live Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?category=2124722"  title="">CD Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/Homebrew/Page"  title="">Homebrew</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://clclt.com/charlotte/EventSearch?eventSection=2362806"  title="">Music Listings</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/features/Category?oid=2124642"  title="">Features/Interviews</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_news" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/blogs/theclog/"  title="">The CLog Blog</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/the-blotter/Category?oid=2124637"  title="">The Blotter</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://clclt.com/charlotte/EventSearch?eventSection=2362805"  title="">Community Events</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/this-modern-world/Content?category=2493369"  title="">This Modern World</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?tag=Question%20the%20Queen%20City"  title="">Question the Queen City</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Arts</h3>
            <ul class="subnav_content" id="SNAV_arts" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/visual-arts/Category?oid=2124649"  title="">Visual Arts</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/performing-arts/Category?oid=2124638"  title="">Performing Arts</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/books/Category?oid=2124625"  title="">Book Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/theclog/archives/comic-afterthoughts/"  title="">Comic Afterthoughts</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?category=2863202"  title="">Gaming</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://clclt.com/charlotte/EventSearch?eventSection=2362804"  title="">Events</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Food &amp; Drink</h3>
            <ul class="subnav_content" id="SNAV_foodanddrink" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/blogs/eatmycharlotte/"  title="">Eat My Charlotte Blog</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://clclt.com/charlotte/LocationSearch?locationSection=2157052"  title="">Restaurant Listings</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?category=2124639"  title="">Restaurant Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/eatmycharlotte/archives/recipe/"  title="">Recipes</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="http://clclt.com/charlotte/EventSearch?eventSection=2362807"  title="">Food-Related Events</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/LocationSearch?feature=Menu"  title="">Restaurant Menus</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Film</h3>
            <ul class="subnav_content" id="SNAV_film" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/features/Category?oid=2124631"  title="">Features</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/reviews/Category?oid=2124646"  title="">Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/view-from-the-couch/Content?category=2124650"  title="">DVD Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/film-clips/Category?oid=2124632"  title="">Film Clips</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/movie/Category?oid=2174166"  title="">Free Movie Tickets</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Sex &amp; Love</h3>
            <ul class="subnav_content" id="SNAV_sexandlove" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/blogs/bangtown/"  title="">Bangtown Blog</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/savage-love/Category?oid=2124702"  title="">Savage Love</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/LustList2014/Page"  title="">Lust List</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Style</h3>
            <ul class="subnav_content" id="SNAV_style" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/creative-living/Category?oid=2389095"  title="">Creative Living</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/style-stalker/Category?oid=2389097"  title="">Style Stalker</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Blogs</h3>
            <ul class="subnav_content" id="SNAV_blogs" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/blogs/theclog/"  title="">The CLog</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/blogs/eatmycharlotte/"  title="">Eat My Charlotte</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/blogs/vibes/"  title="">Vibes</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/blogs/qcafterdark/"  title="">QC After Dark</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/blogs/bangtown/"  title="">Bangtown</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Best of Charlotte</h3>
            <ul class="subnav_content" id="SNAV_bestofcharlotte" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/best-of-charlotte-2016/BestOf?oid=3807595"  title="">2016</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/BestOf?year=2015"  title="">2015</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/BestOf?year=2014"  title="">2014</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/BestOf?year=2013"  title="">2013</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/BestOf?year=2012"  title="">2012</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/bocharlotte2011"  title="">2011</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/bocharlotte2010"  title="">2010</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/bocharlotte2009"  title="">2009</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse CL Events</h3>
            <ul class="subnav_content" id="SNAV_clevents" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ItsPARTYtime/Page"  title="">Best of Charlotte PARTY</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/MargaritaWars2016/Page"  title="">Margarita Wars</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/MooandBrewFest2016/Page"  title="">Craft Beer &amp; Burger Festival</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Ads</h3>
            <ul class="subnav_content" id="SNAV_cldeals" style="display:none;">
          

          

          <li class="">
            <a href="http//clclt.com/charlotte/ShoesfitforaQueen/Page"  title="">CL Deals</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse DNC Du Jour</h3>
            <ul class="subnav_content" id="SNAV_dncdujour" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/dnc-2012/Section?oid=2835403"  title="">DNC Du Jour</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Columns</h3>
            <ul class="subnav_content" id="SNAV_Columns" style="display:none;">
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?category=2124664"  title="">Editor&#39;s Note</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?category=3012001"  title="">Trouble Hunter</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?category=2927374"  title="">Give Me Libertad</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?category=3455200"  title="">The Provocateur</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?category=2955059"  title="">Class Is In Session</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://clclt.com/charlotte/ArticleArchives?category=3144370"  title="">Vodka Yonic</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>

    
  


<!-- End #NavigationHorizontal -->

<div id="SecondaryNavigation" class="GlobalHeader ContentwoTools ">
  
      <img src="/images/buttons/plus-add.png" alt="" />
      <ul>
    
    
    <li><a href="/charlotte/Content?feature=2182902" class="specialIssue">This Week's Cover</a></li>
		
		 | 
		
    
  
    
    <li><a href="/theclog/archives/todays-top-five/" >Today's Top 5 Events</a></li>
		
		 | 
		
    
  
    
    <li><a href="/charlotte/ArticleArchives?category=2124679" >Horoscope</a></li>
		
		 | 
		
    
  
    
    <li><a href="/charlotte/Advertising/Page" >Advertising</a></li>
		
		 | 
		
    
  
    
    <li><a href="/charlotte/Classifieds/Page" >Classifieds</a></li>
		
		 | 
		
    
  
    
    <li><a href="/charlotte/FreeStuff" >Fun + Free Stuff</a></li>
		
		 | 
		
    
  
    
    <li><a href="/charlotte/Xtras/Page" class="promo">Newsletters Signup</a></li>
		
    
  
      </ul>
    
</div>
<div id="PencilBar" class="GlobalHeader ContentwoTools Ad">
  <!-- /88340371/CharlottePencil -->
          <div id="div-gpt-ad-charlottepencil" style="" data-slot="/88340371/CharlottePencil" data-output="asynchronous" data-width="975" data-height="30">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-charlottepencil');
                });
            </script>
          </div>
  
</div>
  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        



  
    <div id="StoryBreadcrumb" class="SpanningFeature ContentwoTools ">
      <p class="issueInfo">
        <span class="date">
          
            <a href="http://clclt.com/charlotte/IssueArchives?issue=2899844">October 25, 2012</a>
          
        </span>

  			
          <a href="http://clclt.com/charlotte/music/Section?oid=2124591">Music</a>
        
        
          &raquo; <a href="http://clclt.com/charlotte/ArticleArchives?category=2124642">Features</a>
        
      </p>
    </div> <!-- end StoryBreadcrumb -->
  





  
  















  
  
  

  
  
  

  
  
  <!-- 
    xxx
    admin: 808579
    serverURl: http://clclt.com
    var.publicDesktopServer = http://clclt.com
    var.shareUrl = http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870
    s/http\:\/\/clclt\.com/http\:\/\/clclt\.com/
    var.shareUrl = http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870
  -->




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="SpanningFeature ContentwoTools ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:16%; height: 20px; float:left;">
        <fb:like href="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:16%; height: 20px; float:left;"><a href="http://twitter.com/share?url=http%3A//clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content%3Foid%3D2899870&text=Christian%20punks%20MxPx%20wrestle%20with%20doubt%20%26mdash%3B%20and%20greatness" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("http://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:16%; height: 20px; float:left;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870" size="medium" count="true"></g:plusone></div> <div class="l0" style="width:16%; height: 20px; float:left;">


  

  

  

  <a href="http://pinterest.com/pin/create/button/?description=Christian%20punks%20MxPx%20wrestle%20with%20doubt%20%26mdash%3B%20and%20greatness&amp;media=http%3A%2F%2Fmedia1.fdncms.com%2Fcharlotte%2Fimager%2Fchristian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness%2Fu%2Fslideshow%2F2899871%2Fmusic_feature2-1_35.jpg&amp;url=http%3A%2F%2Fclclt.com%2Fcharlotte%2Fchristian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness%2FContent%3Foid%3D2899870" class="pin-it-button" count-layout="none">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("http://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</div> <div class="l0" style="width:16%; height: 20px; float:left;"><script src="http://www.stumbleupon.com/hostedbadge.php?s=1&r=http%3A//clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content%3Foid%3D2899870"></script></div> <div class="l0 last" style="width:16%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="http://www.addthis.com/bookmark.php?v=300&pubid=xa-4f5a47bd4299f449" addthis:url="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870" addthis:title="Christian punks MxPx wrestle with doubt &mdash; and greatness" addthis:description="Mike Herrera lets his band grow beyond its beginnings" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("http://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4f5a47bd4299f449", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




  

  

  
    <div id="StoryHeader" class="SpanningFeature ContentwoTools StoryHeader  ">
      <div class="storyHead">
        <h1 class="headline headline-2899870">Christian punks MxPx wrestle with doubt &mdash; and greatness&nbsp;</h1>        
        
          <h2 class="subheadline">Mike Herrera lets his band grow beyond its beginnings</h2>
        
        
          

          <cite class="byline">
            By <a href="http://clclt.com/charlotte/ArticleArchives?author=2548133" rel="author">Jordan Lawrence</a>
          </cite>

          

        
      </div>
    </div> <!-- end StoryHeader -->
  








  
  
  
  




  
  





<div id="StoryLayout" class="SpanningFeature ContentwoTools ">

<!-- Debut output 123456789 -->

  

    
    
    

    
    
    
      
      
  
      
              
      
       
      
      
      <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
      <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
      
      <style>
      div.jp-audio,
      div.jp-video {
        /* Edit the font-size to counteract inherited font sizing.
         * Eg. 1.25em = 1 / 0.8em
         */
        font-size:1.25em;
      }      
      div#storyBody div.inlineAudio,
      div#AudioPlayer div.inlineAudio {
        width: 400px;
        margin: auto;
        }      
      </style>
      
      
      <div id="storyBody" class="page1">
        
        
        

        
        
          <p>Twenty years ago, MxPx emerged with an infectious attack that helped cement the reputation of a particularly divisive sub-genre &mdash; Christian punk. Positive and punchy, the trio of Washington state high schoolers created easily digestible pop-punk earworms that rarely made preaching points of the band's religious ideals but avoided any language or themes that would offend fellow believers. MxPx's success helped pave the way for more overtly religious bands like Relient K and Anberlin. But times change, and these days singer and songwriter Mike Herrera finds himself in a much different place from that of the teenager who applied his spirituality to music.</p>

<div class="contentImageCenter" style="overflow:hidden;">                              <img src="http://media1.fdncms.com/charlotte/imager/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/u/original/2899871/music_feature2-1_35.jpg" width="600" height="505" alt="music_feature2-1_35.jpg" />                                                                              <ul style="width:600px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>

<p>"The reason that I was writing the songs that I was writing was because I grew up going to church," Herrera says, groggy but engaged. It's 3:30 a.m. in Indonesia, where the frontman has just led his MxPx All Stars through a gig on their current world tour. It stops at The Milestone on Oct. 31. A rotating supergroup &mdash; the "All Stars" &mdash; supports Herrera when his regular bandmates, Yuri Ruley and Tom Wisniewski, cannot.</p>

<p>"My family went to church. I had to go to youth group," he continues. "As you grow older, everybody's different. I don't make that a daily part of my life. It's not a big deal, really. It's like that for most people that grow up going to church. I know so many people, fans and friends in the punk industry, that used to go to church when they were kids. There's a ton of us out there, a lot of artists and journalists and music journalists as well. It's funny. We've all had this weird, American Christianity background. And we all go through the same weird experiences from that."</p>

<p>This year, MxPx is celebrating two decades of non-confrontational punk. For Herrera, it's been difficult to continue writing honestly positive songs when his beliefs have changed. At 35, he's no longer a church-going man, and while he won't comment directly on his current political and religious views, he speaks of his musical perspective becoming more "sophisticated," making room for multiple points of view &mdash; not just the rigid Christian background that defined his band's early work.</p>

<p>"I'm not only writing for myself. I'm writing for the audience," Herrera says. "There's a certain amount of honesty that I think some of the younger kids would not be too interested in or stoked about. I'm so different now than when I was writing songs at the beginning of my career &mdash; completely different, in fact. In public life, people don't see us as growing up. They don't see us as changing our views and our ideas about the world and what we believe and what we don't believe and what we think politically. Things are always changing. It's always fluid. It's never exactly the same from album to album to album."</p>

<p>The contrast between Herrera's current outlook and his band's positive energy is captured on <i>Plans Within Plans</i>, the ninth MxPx LP, released earlier this year. The album still occupies the same easily accessible pop-punk structures, but the approach is more aggressive. Pace is pushed to the breaking point. The distortion is rougher. Herrera sings with a road-worn growl.</p>

<p>The biggest difference is in Herrera's lyrics, barbed progressions that hint at grown-up frustrations and secular confusion. "With the conflict on the outside and the fear within/ It's hard to find the courage to begin again," he cries on "In the Past," the lyrics undercut by nervy guitar prickles and pounding drums. "I'm one of the downcast, and I don't want this to last," he goes on before his band mates join him on the shouted chorus: "It's in the past!"</p>

<p>MxPx has always sounded anxious, but on <i>Plans Within Plans</i> the tone is more desperate. Herrera's foundation of religious simplicity has eroded, allowing doubt to complicate his writing. The resulting songs are some of the most exciting in all of the band's expansive catalog.</p>

<p>Herrera has never been one to preach through music. He didn't do it as a devout teenager, and he doesn't do it now as a conflicted adult. When judging his musical peers, he holds them to the same standard.</p>

<p>"If it's good songs, it's good songs," he says. "I try to be positive and inclusive of everyone. A band like Anberlin, they're a really great band. They sound amazing. They write great songs. But also a band like The Swellers, who are atheists. They're both great bands.</p>

<p>"I don't really think of music as one way or the other," Herrera adds. "Although I lean away from the spiritual Christian stuff, way away from it, in fact. To me, it's just insincere and annoying."</p>
        

        
        

        
        
      </div>
    

  

</div> <!-- end StoryLayout -->












  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  











  <div id="ArchiveLink" class="SpanningFeature ContentwoTools ">
    <p class="moreArticles">
      
        <a href="http://clclt.com/charlotte/ArticleArchives?category=2124642">More Features &raquo;</a>
      
      
    </p>
  </div> <!-- end ArchiveLink -->




  <div id="StoryTags" class="SpanningFeature ContentwoTools ">
    <p class="tags">Tags: <a href="/charlotte/ArticleArchives?category=2124642" rel="tag">Features</a>, <a href="/charlotte/ArticleArchives?tag=MxPx%20All%20Stars" rel="tag">MxPx All Stars</a>, <a href="/charlotte/ArticleArchives?tag=Mike%20Herrera" rel="tag">Mike Herrera</a>, <a href="/charlotte/ArticleArchives?tag=Yuri%20Ruley%20and%20Tom%20Wisniewski" rel="tag">Yuri Ruley and Tom Wisniewski</a>, <a href="/charlotte/ArticleArchives?tag=punk" rel="tag">punk</a>, <a href="/charlotte/ArticleArchives?tag=Christianity" rel="tag">Christianity</a>, <a href="/charlotte/ArticleArchives?tag=Plans%20Within%20Plans" rel="tag">Plans Within Plans</a>, <a href="/charlotte/ArticleArchives?tag=religion" rel="tag">religion</a></p>          
  </div> <!-- end StoryTags -->

















  












  






  
  
















  
  
    
  
  
  <div id="TallBar" class="SpanningFeature ContentwoTools ">
    <ul>
      <li class="l0 first" style="width:50%">
        <fb:like href="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870" send="true" width="275" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="standard"></fb:like></li> <li class="l0" style="width:12%;"><a href="http://twitter.com/share?url=http%3A//clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content%3Foid%3D2899870&text=Christian%20punks%20MxPx%20wrestle%20with%20doubt%20%26mdash%3B%20and%20greatness" class="twitter-share-button" data-count="vertical">Tweet</a>
<script>
  dnLoadScript("http://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0" style="width:12%;">


  

  

  <a href="http://pinterest.com/pin/create/button/?description=Christian%20punks%20MxPx%20wrestle%20with%20doubt%20%26mdash%3B%20and%20greatness&amp;media=http%3A%2F%2Fmedia1.fdncms.com%2Fcharlotte%2Fimager%2Fchristian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness%2Fu%2Fslideshow%2F2899871%2Fmusic_feature2-1_35.jpg&amp;url=http%3A%2F%2Fclclt.com%2Fcharlotte%2Fchristian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness%2FContent%3Foid%3D2899870" class="pin-it-button" count-layout="vertical">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("http://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</li> <li class="l0 last" style="width:12%;">




  <div class="addthis_toolbox addthis_default_style"><a addthis:url="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870" addthis:title="Christian punks MxPx wrestle with doubt &mdash; and greatness" addthis:description="Mike Herrera lets his band grow beyond its beginnings" class="addthis_counter"></a></div>
  <script type="text/javascript">
    dnLoadScript("http://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-4f5a47bd4299f449", true);
  </script>


      </li>
    </ul>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  















  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="Comments" class="SpanningFeature ContentwoTools CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
            <form action="/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content" method="get" class="fr ar" id="sort" onSubmit="return false;">
              <div class="sortSpinner" style="display:none;">&nbsp;</div>
              <label for="sort">Sort</label>
              <select name="sort" id="sortSelect">
                <option value="asc" selected="selected">Oldest to Newest</option>
                <option value="desc" >Newest to Oldest</option>
                
                <option value="liked" >Most Liked</option>
              </select>
            </form>
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments (<span id="comments_total" class="commentsTotalUpdate">22</span>)
            </div>
            
          </h3>
        </div>
        
          <div class="commentsTopBar">
            <p class="showing">
              Showing
              <strong>1-<span class="commentsShowingUpdate">22</span></strong>
              of <span class="commentsTotalUpdate">22</span>
            </p>
            <p class="jump">
              
                <a href="#CommentsPostCommentForm">Add a comment</a>
              
            </p>
          </div>
        
        
        <div id="Comments_commentContent" class="commentContent">
          <div class="commentSpinner" style="clear:both;">&nbsp;</div>
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="2899870" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/charlotte/Rss.xml?id=comments&amp;oid=2899870" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
              <div class="showing">
       Showing <strong>1-<span class="commentsShowingUpdate">22</span></strong> of <span class="commentsTotalUpdate">22</span>
    </div>
            
          </div>          
          
        <hr />

        

        
          

          <form id="CommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:true}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="2899870" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            <p><i>Creative Loafing</i> encourages a healthy discussion on its website from all
sides of the conversation, but we reserve the right to delete any comments
that detract from that. Violence, racism and personal attacks that go
beyond the pale will not be tolerated.</p>
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="Comments_commentSubscribe" value="yes"> <label for="Comments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  










  

  

  
  

  

  









      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          







  
  
      <div id="LatestInCategory" class="MainColumn1 ContentwoTools ">
        <h3 class="latestfeatures"><span class="headingText">Latest in Features</span></h3>
        <ul class="moduleList">
    
    
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://clclt.com/charlotte/paul-richards-talks-california-guitar-trio/Content?oid=3816669">Paul Richards talks California Guitar Trio</a>
    </h4>
    
      <h5 class="subhead">
        Three's no crowd
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Samir Shukla |
        
        12.14.16
      </li>
    </ul>
  </li>
    
  
    
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://clclt.com/charlotte/deep-6-division-duo-releases-bruising-debut-album/Content?oid=3815822">Deep 6 Division duo releases bruising debut album</a>
    </h4>
    
      <h5 class="subhead">
        Pulling no punches
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Ryan Pitkin |
        
        12.07.16
      </li>
    </ul>
  </li>
    
  
    
    <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://clclt.com/charlotte/elise-davis-tosses-her-token/Content?oid=3814736">Elise Davis tosses her 'token'</a>
    </h4>
    
      <h5 class="subhead">
        The alternative route
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Anita Overcash |
        
        11.30.16
      </li>
    </ul>
  </li>
    
  
         <li class="l0 storyItem more">
           <a href="http://clclt.com/charlotte/ArticleArchives?category=2124642" class="more">More &raquo;</a>
         </li>
         </ul>
      </div>
    



    

    



  

  

  
    <div id="AltWeekliesDynamic" class="MainColumn1 ContentwoTools " style="display:none">
      <h3><span class="headingText">Related Stories from <a href="http://www.altweeklies.com/" target="_blank">Altweeklies.com</a></span></h3>
  
      <script type="text/javascript" src="/foundation/scripts/altweeklies-include.js"></script>
      <script type="text/javascript"><!--
        altweekliesInclude({
            id: "AltWeekliesDynamic-Results",
            max: "3",
            section: "music",
            pubexclude: ,
            summaries: true,
            callback: function (t) {
                if (t.match(/\S/)) $("AltWeekliesDynamic").show();
            }
        });
      //--></script>
  
      <div id="AltWeekliesDynamic-Results"></div>
    </div>
  



        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          







  

  
    
        <div id="PeopleWhoLiked" class="MainColumn2 ContentwoTools ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://clclt.com/charlotte/11-must-see-outdoor-concerts-in-charlotte/Content?oid=3611528">11 Must-See Outdoor Concerts In Charlotte</a><a href="http://clclt.com/charlotte/11-must-see-outdoor-concerts-in-charlotte/Content?oid=3611528#readerComments">&nbsp;<span class="commentCount">4</span></a>
    </h4>
    
      <h5 class="subhead">
        Sounds for the summer season
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Jeff Hahne |
        
        05.27.15
      </li>
    </ul>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://clclt.com/charlotte/shakey-graves-work-in-progress/Content?oid=3614071">Shakey Graves' Work in Progress</a><a href="http://clclt.com/charlotte/shakey-graves-work-in-progress/Content?oid=3614071#readerComments">&nbsp;<span class="commentCount">1</span></a>
    </h4>
    
      <h5 class="subhead">
        Alejandro Rose-Garcia continues developing his evolving sound
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Jeff Hahne |
        
        06.10.15
      </li>
    </ul>
  </li>
      
      
    
          </ul>
        </div>
      
               








  

  

  
    <div id="MorebyThisAuthorWrapper" class="MainColumn2 ContentwoTools Wrapper">

    
      
      

        
            <div id="MorebyThisAuthor" class="MainColumn2 ContentwoTools ">
              <h3><span class="headingText">More by Jordan Lawrence</span></h3>
              <ul class="moduleList">
          
          

          <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://clclt.com/charlotte/self-aware-records-celebrates-five-years/Content?oid=3418289">Self Aware Records celebrates five years</a>
    </h4>
    
      <h5 class="subhead">
        A diverse mix of acts will rock the two-day festival in honor of Joshua and Sarah Robbins's DIY label
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Jordan Lawrence |
        
        06.04.14
      </li>
    </ul>
  </li>

          
        
          

          <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://clclt.com/charlotte/self-awares-greatest-hits/Content?oid=3418294">Self Aware's greatest hits</a>
    </h4>
    
      <h5 class="subhead">
        As the local label celebrates its five-year anniversary, we offer up five of its greatest hits.
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Jordan Lawrence |
        
        06.04.14
      </li>
    </ul>
  </li>

          
        
          

          <li class="l0 storyItem">
    <h4 class="headline">
      <a href="http://clclt.com/charlotte/cd-review-brain-fandnes-empty-set/Content?oid=3344754">CD Review: Brain F&ne;'s <i>Empty Set</i></a>
    </h4>
    
      <h5 class="subhead">
        Sorry State; Release date: Feb. 11, 2014
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Jordan Lawrence |
        
        03.07.14
      </li>
    </ul>
  </li>

          
        
               <li class="l0 storyItem">
                 <a href="http://clclt.com/charlotte/ArticleArchives?author=2548133" class="more">More &raquo;</a>
               </li>
               </ul>
            </div>
          

      
    
   </div>  
   
  



        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        












<div id="SearchEvents" class="SpanningIsland ContentwoTools ">
  <h2 id="search-events">Search Events</h2>

  <div class="tabs">
    <div class="tabBack tabLeft tab"><a href="#">all events</a></div>
    <div class="tabCurrent tabCenter tab"><a href="#">concerts</a></div>
    <div class="tabBack tabCenter tab"><a href="#">restaurants</a></div>
    <div class="tabBack tabRight tab"><a href="#">movie times</a></div>
  </div><!-- close .tabs -->

  <div class="clear"></div>


  

  <div class="calendarBody" style="display:none">
    <form name="eventSearchForm" method="get" action="http://clclt.com/charlotte/EventSearch">
      <select name="narrowByDate" class="narrowDate">
    
    
      <option value="">-All Dates-</option>
      
      
        <option value="Today">Today</option>
      
      
        <option value="Tomorrow">Tomorrow</option>
      
      
        <option value="This Weekend">This Weekend</option>
      
      
        <option value="This Week">This Week</option>
      
      <option value="">--------------------</option>
      
        
        
          <option value="2016-12-20">Tuesday, December 20</option>
        
      
        
        
          <option value="2016-12-21">Wednesday, December 21</option>
        
      
        
        
          <option value="2016-12-22">Thursday, December 22</option>
        
      
        
        
          <option value="2016-12-23">Friday, December 23</option>
        
      
        
        
          <option value="2016-12-24">Saturday, December 24</option>
        
      
        
        
          <option value="2016-12-25">Sunday, December 25</option>
        
      
        
        
          <option value="2016-12-26">Monday, December 26</option>
        
      
        
        
          <option value="2016-12-27">Tuesday, December 27</option>
        
      
        
        
          <option value="2016-12-28">Wednesday, December 28</option>
        
      
        
        
          <option value="2016-12-29">Thursday, December 29</option>
        
      
        
        
          <option value="2016-12-30">Friday, December 30</option>
        
      
        
        
          <option value="2016-12-31">Saturday, December 31</option>
        
      
        
        
          <option value="2017-01-01">Sunday, January  1</option>
        
      
        
        
          <option value="2017-01-02">Monday, January  2</option>
        
      
        
        
          <option value="2017-01-03">Tuesday, January  3</option>
        
      
        
        
          <option value="2017-01-04">Wednesday, January  4</option>
        
      
        
        
          <option value="2017-01-05">Thursday, January  5</option>
        
      
        
        
          <option value="2017-01-06">Friday, January  6</option>
        
      
        
        
          <option value="2017-01-07">Saturday, January  7</option>
        
      
        
        
          <option value="2017-01-08">Sunday, January  8</option>
        
      
        
        
          <option value="2017-01-09">Monday, January  9</option>
        
      
        
        
          <option value="2017-01-10">Tuesday, January 10</option>
        
      
        
        
          <option value="2017-01-11">Wednesday, January 11</option>
        
      
        
        
          <option value="2017-01-12">Thursday, January 12</option>
        
      
        
        
          <option value="2017-01-13">Friday, January 13</option>
        
      
        
        
          <option value="2017-01-14">Saturday, January 14</option>
        
      
        
        
          <option value="2017-01-15">Sunday, January 15</option>
        
      
        
        
          <option value="2017-01-16">Monday, January 16</option>
        
      
        
        
          <option value="2017-01-17">Tuesday, January 17</option>
        
      
        
        
          <option value="2017-01-18">Wednesday, January 18</option>
        
      
        
        
          <option value="2017-01-19">Thursday, January 19</option>
        
      
    
  </select>

      <select name="eventCategory" class="eventCategory">
        <option value="">-All Event Categories-</option>
        
          
            <option value="2362804" >ARTS AGENDA</option>
          
          
            <option value="2362809" >&nbsp;&nbsp;Classical Music</option>
          
        
          
          
            <option value="2167939" >&nbsp;&nbsp;Comedy</option>
          
        
          
          
            <option value="2167942" >&nbsp;&nbsp;Film</option>
          
        
          
          
            <option value="2167309" >&nbsp;&nbsp;Museums</option>
          
        
          
          
            <option value="2167944" >&nbsp;&nbsp;Readings &amp; Signings</option>
          
        
          
          
            <option value="2167324" >&nbsp;&nbsp;Spoken Word</option>
          
        
          
          
            <option value="2167253" >&nbsp;&nbsp;Theater/Dance/Performance Art</option>
          
        
          
          
            <option value="2167937" >&nbsp;&nbsp;Visual Arts</option>
          
        
          
            <option value="2362805" >COMMUNITY HAPPENINGS</option>
          
          
            <option value="2167263" >&nbsp;&nbsp;Benefits &amp; Fundraisers</option>
          
        
          
          
            <option value="2167315" >&nbsp;&nbsp;Clubs &amp; Organizations</option>
          
        
          
          
            <option value="2167267" >&nbsp;&nbsp;Family</option>
          
        
          
          
            <option value="2167380" >&nbsp;&nbsp;Festivals/Events</option>
          
        
          
          
            <option value="2167265" >&nbsp;&nbsp;Gay &amp; Lesbian</option>
          
        
          
          
            <option value="2167469" >&nbsp;&nbsp;Health &amp; Fitness</option>
          
        
          
          
            <option value="2167425" >&nbsp;&nbsp;Holiday</option>
          
        
          
          
            <option value="2167943" >&nbsp;&nbsp;Lectures, Classes &amp; Seminars</option>
          
        
          
          
            <option value="2167494" >&nbsp;&nbsp;Nightlife</option>
          
        
          
          
            <option value="2362808" >&nbsp;&nbsp;Sex &amp; Love</option>
          
        
          
          
            <option value="2167275" >&nbsp;&nbsp;Singles</option>
          
        
          
          
            <option value="2167947" >&nbsp;&nbsp;Sports &amp; Recreation</option>
          
        
          
          
            <option value="2167276" >&nbsp;&nbsp;Support Groups</option>
          
        
          
          
            <option value="2167277" >&nbsp;&nbsp;Volunteers/Public Life</option>
          
        
          
            <option value="2362807" >FOOD &amp; DRINK</option>
          
          
            <option value="2167468" >&nbsp;&nbsp;Culinary</option>
          
        
          
          
            <option value="2167434" >&nbsp;&nbsp;Wine/Cocktails</option>
          
        
          
            <option value="2362806" >MUSIC EVENTS</option>
          
          
            <option value="2167327" >&nbsp;&nbsp;Blues/Roots/International</option>
          
        
          
          
            <option value="2167470" >&nbsp;&nbsp;Classical/Jazz/Smooth</option>
          
        
          
          
            <option value="2167338" >&nbsp;&nbsp;Country/Folk</option>
          
        
          
          
            <option value="2167342" >&nbsp;&nbsp;DJ/Electronic</option>
          
        
          
          
            <option value="2167945" >&nbsp;&nbsp;General</option>
          
        
          
          
            <option value="2167407" >&nbsp;&nbsp;Hip-Hop/Soul/R&amp;B</option>
          
        
          
          
            <option value="2441149" >&nbsp;&nbsp;Pop/Rock</option>
          
        
      </select>

      <input type="text" size="18" name="keywords" title="Enter keyword" class="text" value="" />
      <input type="submit" class="submit" value="Go" />
    </form>
  </div><!-- close .calendarBody -->


  

  <div class="calendarBody" >
    <form name="eventSearchForm" method="get" action="http://clclt.com/charlotte/EventSearch">
      <input type="hidden" name="eventSection" value="2362806">
      <select name="narrowByDate" class="narrowDate">
    
    
      <option value="">-All Dates-</option>
      
      
        <option value="Today">Today</option>
      
      
        <option value="Tomorrow">Tomorrow</option>
      
      
        <option value="This Weekend">This Weekend</option>
      
      
        <option value="This Week">This Week</option>
      
      <option value="">--------------------</option>
      
        
        
          <option value="2016-12-20">Tuesday, December 20</option>
        
      
        
        
          <option value="2016-12-21">Wednesday, December 21</option>
        
      
        
        
          <option value="2016-12-22">Thursday, December 22</option>
        
      
        
        
          <option value="2016-12-23">Friday, December 23</option>
        
      
        
        
          <option value="2016-12-24">Saturday, December 24</option>
        
      
        
        
          <option value="2016-12-25">Sunday, December 25</option>
        
      
        
        
          <option value="2016-12-26">Monday, December 26</option>
        
      
        
        
          <option value="2016-12-27">Tuesday, December 27</option>
        
      
        
        
          <option value="2016-12-28">Wednesday, December 28</option>
        
      
        
        
          <option value="2016-12-29">Thursday, December 29</option>
        
      
        
        
          <option value="2016-12-30">Friday, December 30</option>
        
      
        
        
          <option value="2016-12-31">Saturday, December 31</option>
        
      
        
        
          <option value="2017-01-01">Sunday, January  1</option>
        
      
        
        
          <option value="2017-01-02">Monday, January  2</option>
        
      
        
        
          <option value="2017-01-03">Tuesday, January  3</option>
        
      
        
        
          <option value="2017-01-04">Wednesday, January  4</option>
        
      
        
        
          <option value="2017-01-05">Thursday, January  5</option>
        
      
        
        
          <option value="2017-01-06">Friday, January  6</option>
        
      
        
        
          <option value="2017-01-07">Saturday, January  7</option>
        
      
        
        
          <option value="2017-01-08">Sunday, January  8</option>
        
      
        
        
          <option value="2017-01-09">Monday, January  9</option>
        
      
        
        
          <option value="2017-01-10">Tuesday, January 10</option>
        
      
        
        
          <option value="2017-01-11">Wednesday, January 11</option>
        
      
        
        
          <option value="2017-01-12">Thursday, January 12</option>
        
      
        
        
          <option value="2017-01-13">Friday, January 13</option>
        
      
        
        
          <option value="2017-01-14">Saturday, January 14</option>
        
      
        
        
          <option value="2017-01-15">Sunday, January 15</option>
        
      
        
        
          <option value="2017-01-16">Monday, January 16</option>
        
      
        
        
          <option value="2017-01-17">Tuesday, January 17</option>
        
      
        
        
          <option value="2017-01-18">Wednesday, January 18</option>
        
      
        
        
          <option value="2017-01-19">Thursday, January 19</option>
        
      
    
  </select>
      <select name="neighborhood" class="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
        <option value="2157330" >&nbsp;&nbsp;General Charlotte Area</option>
      
        
          <option value="2157338" >NORTH CHARLOTTE</option>
        
        <option value="2157356" >&nbsp;&nbsp;Concord/Kannapolis</option>
      
        
        <option value="2157346" >&nbsp;&nbsp;Cornelius</option>
      
        
        <option value="2157342" >&nbsp;&nbsp;Dilworth</option>
      
        
        <option value="3375682" >&nbsp;&nbsp;Huntersville</option>
      
        
        <option value="2157334" >&nbsp;&nbsp;NoDa</option>
      
        
        <option value="3147577" >&nbsp;&nbsp;North End</option>
      
        
        <option value="3375816" >&nbsp;&nbsp;Northlake</option>
      
        
        <option value="2157333" >&nbsp;&nbsp;University</option>
      
        
        <option value="3381279" >&nbsp;&nbsp;Davidson</option>
      
        
        <option value="3381463" >&nbsp;&nbsp;Mooresville</option>
      
        
          <option value="2157336" >EAST SIDE</option>
        
        <option value="2157344" >&nbsp;&nbsp;East Charlotte</option>
      
        
        <option value="2157345" >&nbsp;&nbsp;Elizabeth</option>
      
        
        <option value="2157354" >&nbsp;&nbsp;Plaza Midwood</option>
      
        
          <option value="2157340" >SOUTH CHARLOTTE</option>
        
        <option value="2157353" >&nbsp;&nbsp;Ballantyne</option>
      
        
          <option value="3147596" >CENTRAL CHARLOTTE</option>
        
        <option value="2157343" >&nbsp;&nbsp;Midtown</option>
      
        
          <option value="2157340" >SOUTH CHARLOTTE</option>
        
        <option value="3375684" >&nbsp;&nbsp;Madison Park/Montford</option>
      
        
        <option value="2157347" >&nbsp;&nbsp;Matthews</option>
      
        
        <option value="2157351" >&nbsp;&nbsp;SouthPark</option>
      
        
        <option value="2157348" >&nbsp;&nbsp;Myers Park</option>
      
        
        <option value="2157362" >&nbsp;&nbsp;South End</option>
      
        
        <option value="2157349" >&nbsp;&nbsp;Pineville/Hwy 51</option>
      
        
        <option value="3375685" >&nbsp;&nbsp;Steele Creek</option>
      
        
        <option value="2157350" >&nbsp;&nbsp;South Charlotte</option>
      
        
          <option value="3147596" >CENTRAL CHARLOTTE</option>
        
        <option value="2157352" >&nbsp;&nbsp;Uptown</option>
      
        
          <option value="2157340" >SOUTH CHARLOTTE</option>
        
        <option value="3381280" >&nbsp;&nbsp;Cotswold</option>
      
        
          <option value="2157341" >WEST CHARLOTTE</option>
        
        <option value="3375683" >&nbsp;&nbsp;Beatties Ford Road Corridor</option>
      
        
        <option value="3147582" >&nbsp;&nbsp;FreeMore West</option>
      
        
        <option value="2157366" >&nbsp;&nbsp;Gastonia</option>
      
        
        <option value="2390972" >&nbsp;&nbsp;Westside</option>
      
        
          <option value="2157339" >SOUTH CAROLINA</option>
        
        <option value="2157369" >&nbsp;&nbsp;Fort Mill</option>
      
        
        <option value="2157368" >&nbsp;&nbsp;Rock Hill</option>
      
        
          <option value="3399281" >OUTSIDE CHARLOTTE</option>
        
        <option value="3399284" >&nbsp;&nbsp;Outside Charlotte</option>
      
    
  </select>
      <input type="text" size="18" name="keywords" title="Enter keyword" class="text" value="" />
      <input type="submit" class="submit" value="Go" />
    </form>
  </div><!-- close .calendarBody -->


  

  <div class="calendarBody" style="display:none">
    <form name="locationSearchForm" method="get" action="http://clclt.com/charlotte/LocationSearch">
      <input type="hidden" name="locationSection" value="2157052">

      <select name="locationCategory" class="locationCategory">
        <option value="">-All Cuisines-</option>
        
          <option value="2157167" >&nbsp;&nbsp;Afghani</option>
        
          <option value="2157168" >&nbsp;&nbsp;African</option>
        
          <option value="2157169" >&nbsp;&nbsp;American</option>
        
          <option value="2160538" >&nbsp;&nbsp;American, Modern/New</option>
        
          <option value="2157171" >&nbsp;&nbsp;Argentine</option>
        
          <option value="2160539" >&nbsp;&nbsp;Argentinean</option>
        
          <option value="2157172" >&nbsp;&nbsp;Armenian</option>
        
          <option value="2157173" >&nbsp;&nbsp;Asian</option>
        
          <option value="2157309" >&nbsp;&nbsp;Bakery</option>
        
          <option value="2157229" >&nbsp;&nbsp;Bar food</option>
        
          <option value="2157174" >&nbsp;&nbsp;Barbecue</option>
        
          <option value="2157312" >&nbsp;&nbsp;Brazilian</option>
        
          <option value="2157175" >&nbsp;&nbsp;Breakfast</option>
        
          <option value="2160540" >&nbsp;&nbsp;Brew Pubs</option>
        
          <option value="2160541" >&nbsp;&nbsp;British/English</option>
        
          <option value="2157310" >&nbsp;&nbsp;Buffet</option>
        
          <option value="2157176" >&nbsp;&nbsp;Burgers</option>
        
          <option value="2157185" >&nbsp;&nbsp;Cajun/Creole</option>
        
          <option value="2157178" >&nbsp;&nbsp;Cal-Mex</option>
        
          <option value="2157177" >&nbsp;&nbsp;California</option>
        
          <option value="2157179" >&nbsp;&nbsp;Cambodian</option>
        
          <option value="2157180" >&nbsp;&nbsp;Cantonese</option>
        
          <option value="2157181" >&nbsp;&nbsp;Caribbean</option>
        
          <option value="2157222" >&nbsp;&nbsp;Central/South American</option>
        
          <option value="2157182" >&nbsp;&nbsp;Chinese</option>
        
          <option value="2160542" >&nbsp;&nbsp;Colombian</option>
        
          <option value="2157313" >&nbsp;&nbsp;Columbian</option>
        
          <option value="2157184" >&nbsp;&nbsp;Continental</option>
        
          <option value="2157318" >&nbsp;&nbsp;Crepes</option>
        
          <option value="2157186" >&nbsp;&nbsp;Cuban</option>
        
          <option value="2157187" >&nbsp;&nbsp;Deli</option>
        
          <option value="2157183" >&nbsp;&nbsp;Desserts</option>
        
          <option value="2157188" >&nbsp;&nbsp;Diner</option>
        
          <option value="2157190" >&nbsp;&nbsp;Eastern European</option>
        
          <option value="2157189" >&nbsp;&nbsp;Ethiopian</option>
        
          <option value="2160543" >&nbsp;&nbsp;Filipino</option>
        
          <option value="2157319" >&nbsp;&nbsp;Fondue</option>
        
          <option value="2157191" >&nbsp;&nbsp;French</option>
        
          <option value="2362518" >&nbsp;&nbsp;General Dining</option>
        
          <option value="2157192" >&nbsp;&nbsp;German</option>
        
          <option value="2157193" >&nbsp;&nbsp;Greek</option>
        
          <option value="2157194" >&nbsp;&nbsp;Guatemalan</option>
        
          <option value="2157315" >&nbsp;&nbsp;Honduran</option>
        
          <option value="2157307" >&nbsp;&nbsp;Hot dogs</option>
        
          <option value="2157316" >&nbsp;&nbsp;Hunan</option>
        
          <option value="2157195" >&nbsp;&nbsp;Hungarian</option>
        
          <option value="2160544" >&nbsp;&nbsp;Ice cream</option>
        
          <option value="2157196" >&nbsp;&nbsp;Indian</option>
        
          <option value="2157321" >&nbsp;&nbsp;Indian (Northern)</option>
        
          <option value="2157320" >&nbsp;&nbsp;Indian (Southern)</option>
        
          <option value="2157197" >&nbsp;&nbsp;Indonesian</option>
        
          <option value="2157324" >&nbsp;&nbsp;Iranian</option>
        
          <option value="2157325" >&nbsp;&nbsp;Iraqi</option>
        
          <option value="2157198" >&nbsp;&nbsp;Irish</option>
        
          <option value="2157199" >&nbsp;&nbsp;Israeli</option>
        
          <option value="2157200" >&nbsp;&nbsp;Italian</option>
        
          <option value="2157322" >&nbsp;&nbsp;Italian (Northern)</option>
        
          <option value="2157201" >&nbsp;&nbsp;Italian (Southern)</option>
        
          <option value="2157311" >&nbsp;&nbsp;Jamaican</option>
        
          <option value="2157202" >&nbsp;&nbsp;Japanese</option>
        
          <option value="2157203" >&nbsp;&nbsp;Korean</option>
        
          <option value="2157323" >&nbsp;&nbsp;Latino</option>
        
          <option value="2157204" >&nbsp;&nbsp;Lebanese</option>
        
          <option value="2157317" >&nbsp;&nbsp;Mandarin</option>
        
          <option value="2157205" >&nbsp;&nbsp;Mediterranean</option>
        
          <option value="2157206" >&nbsp;&nbsp;Mexican</option>
        
          <option value="2157207" >&nbsp;&nbsp;Middle Eastern</option>
        
          <option value="2157306" >&nbsp;&nbsp;Moroccan</option>
        
          <option value="2160547" >&nbsp;&nbsp;Needs Dining Category</option>
        
          <option value="2157170" >&nbsp;&nbsp;New American</option>
        
          <option value="2157326" >&nbsp;&nbsp;Pakistani</option>
        
          <option value="2157208" >&nbsp;&nbsp;Persian</option>
        
          <option value="2157314" >&nbsp;&nbsp;Peruvian</option>
        
          <option value="2157209" >&nbsp;&nbsp;Phillipino</option>
        
          <option value="2157210" >&nbsp;&nbsp;Pizza</option>
        
          <option value="2157211" >&nbsp;&nbsp;Polish</option>
        
          <option value="2157327" >&nbsp;&nbsp;Portugese</option>
        
          <option value="2160545" >&nbsp;&nbsp;Portuguese</option>
        
          <option value="2157212" >&nbsp;&nbsp;Puerto Rican</option>
        
          <option value="2157213" >&nbsp;&nbsp;Romanian</option>
        
          <option value="2157214" >&nbsp;&nbsp;Russian</option>
        
          <option value="2157215" >&nbsp;&nbsp;Salads</option>
        
          <option value="2157216" >&nbsp;&nbsp;Salvadoran</option>
        
          <option value="2157217" >&nbsp;&nbsp;Sandwiches</option>
        
          <option value="2157218" >&nbsp;&nbsp;Seafood</option>
        
          <option value="2157219" >&nbsp;&nbsp;Serbian</option>
        
          <option value="2157220" >&nbsp;&nbsp;Soul food</option>
        
          <option value="2157221" >&nbsp;&nbsp;Soup</option>
        
          <option value="2157308" >&nbsp;&nbsp;Southern</option>
        
          <option value="2157223" >&nbsp;&nbsp;Southwestern</option>
        
          <option value="2157224" >&nbsp;&nbsp;Spanish</option>
        
          <option value="2157225" >&nbsp;&nbsp;Steak</option>
        
          <option value="2157226" >&nbsp;&nbsp;Stir Fry</option>
        
          <option value="2157227" >&nbsp;&nbsp;Sushi</option>
        
          <option value="2157228" >&nbsp;&nbsp;Szechuan</option>
        
          <option value="2157328" >&nbsp;&nbsp;Tapas</option>
        
          <option value="2157230" >&nbsp;&nbsp;Tex-Mex</option>
        
          <option value="2157231" >&nbsp;&nbsp;Thai</option>
        
          <option value="2157232" >&nbsp;&nbsp;Turkish</option>
        
          <option value="2160546" >&nbsp;&nbsp;Vegan</option>
        
          <option value="2157233" >&nbsp;&nbsp;Vegetarian</option>
        
          <option value="2157234" >&nbsp;&nbsp;Vietnamese</option>
        
          <option value="2157235" >&nbsp;&nbsp;West African</option>
        
      </select>

      <select name="neighborhood" class="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
        <option value="2157330" >&nbsp;&nbsp;General Charlotte Area</option>
      
        
          <option value="2157338" >NORTH CHARLOTTE</option>
        
        <option value="2157356" >&nbsp;&nbsp;Concord/Kannapolis</option>
      
        
        <option value="2157346" >&nbsp;&nbsp;Cornelius</option>
      
        
        <option value="2157342" >&nbsp;&nbsp;Dilworth</option>
      
        
        <option value="3375682" >&nbsp;&nbsp;Huntersville</option>
      
        
        <option value="2157334" >&nbsp;&nbsp;NoDa</option>
      
        
        <option value="3147577" >&nbsp;&nbsp;North End</option>
      
        
        <option value="3375816" >&nbsp;&nbsp;Northlake</option>
      
        
        <option value="2157333" >&nbsp;&nbsp;University</option>
      
        
        <option value="3381279" >&nbsp;&nbsp;Davidson</option>
      
        
        <option value="3381463" >&nbsp;&nbsp;Mooresville</option>
      
        
          <option value="2157336" >EAST SIDE</option>
        
        <option value="2157344" >&nbsp;&nbsp;East Charlotte</option>
      
        
        <option value="2157345" >&nbsp;&nbsp;Elizabeth</option>
      
        
        <option value="2157354" >&nbsp;&nbsp;Plaza Midwood</option>
      
        
          <option value="2157340" >SOUTH CHARLOTTE</option>
        
        <option value="2157353" >&nbsp;&nbsp;Ballantyne</option>
      
        
          <option value="3147596" >CENTRAL CHARLOTTE</option>
        
        <option value="2157343" >&nbsp;&nbsp;Midtown</option>
      
        
          <option value="2157340" >SOUTH CHARLOTTE</option>
        
        <option value="3375684" >&nbsp;&nbsp;Madison Park/Montford</option>
      
        
        <option value="2157347" >&nbsp;&nbsp;Matthews</option>
      
        
        <option value="2157351" >&nbsp;&nbsp;SouthPark</option>
      
        
        <option value="2157348" >&nbsp;&nbsp;Myers Park</option>
      
        
        <option value="2157362" >&nbsp;&nbsp;South End</option>
      
        
        <option value="2157349" >&nbsp;&nbsp;Pineville/Hwy 51</option>
      
        
        <option value="3375685" >&nbsp;&nbsp;Steele Creek</option>
      
        
        <option value="2157350" >&nbsp;&nbsp;South Charlotte</option>
      
        
          <option value="3147596" >CENTRAL CHARLOTTE</option>
        
        <option value="2157352" >&nbsp;&nbsp;Uptown</option>
      
        
          <option value="2157340" >SOUTH CHARLOTTE</option>
        
        <option value="3381280" >&nbsp;&nbsp;Cotswold</option>
      
        
          <option value="2157341" >WEST CHARLOTTE</option>
        
        <option value="3375683" >&nbsp;&nbsp;Beatties Ford Road Corridor</option>
      
        
        <option value="3147582" >&nbsp;&nbsp;FreeMore West</option>
      
        
        <option value="2157366" >&nbsp;&nbsp;Gastonia</option>
      
        
        <option value="2390972" >&nbsp;&nbsp;Westside</option>
      
        
          <option value="2157339" >SOUTH CAROLINA</option>
        
        <option value="2157369" >&nbsp;&nbsp;Fort Mill</option>
      
        
        <option value="2157368" >&nbsp;&nbsp;Rock Hill</option>
      
        
          <option value="3399281" >OUTSIDE CHARLOTTE</option>
        
        <option value="3399284" >&nbsp;&nbsp;Outside Charlotte</option>
      
    
  </select>

      <input type="text" size="18" name="keywords" title="Enter keyword" class="text" value="" />
      <input type="submit" class="submit" value="Go" />
    </form>
  </div><!-- close .calendarBody -->


  

  <div class="calendarBody" style="display:none">
    <form name="movietimesSearchForm" id="movietimesSearchFormMovie" method="get" action="http://clclt.com/charlotte/MovieTimes">
      <select name="film" class="film">
        <option value="">-All Films-</option>
        
      </select>

      <select name="narrowByDate" class="narrowDate">
        <option value="2016-12-20">Today</option>
        
          
          
            <option value="2016-12-21">Wednesday, December 21</option>
          
        
          
          
            <option value="2016-12-22">Thursday, December 22</option>
          
        
          
          
            <option value="2016-12-23">Friday, December 23</option>
          
        
          
          
            <option value="2016-12-24">Saturday, December 24</option>
          
        
          
          
            <option value="2016-12-25">Sunday, December 25</option>
          
        
          
          
            <option value="2016-12-26">Monday, December 26</option>
          
        
      </select>

      <input type="submit" class="submit" value="Go" />
    </form>
  </div><!-- close .calendarBody -->

</div><!-- close #SearchEvents -->

<div id="eventLinks">
  <a href="http://posting.clclt.com/charlotte/Events/AddEvent">&raquo; submit an event</a>
  <a href="http://clclt.com/charlotte/EventSearch">&raquo; browse all events</a>
</div>






<script type="text/javascript">
<!--
  Event.observe(document, "dom:loaded", function () {
      dnSetupTabGroup(
          $$("#SearchEvents div.tabs>div"),
          $$("#SearchEvents div.calendarBody"),
          "tabCurrent", "tabBack", 1
      );

      // Deactivate links.
      $$("#SearchEvents div.tabs>div a").each(function (a) {
          a.onclick = function () { return false; };
      });
  });
//-->
</script>
<div id="oratvWidget" class="SpanningIsland ContentwoTools Ad">
  <iframe width="300" height="168" src="//www.ora.tv/embed/partner/altweekly/playlist/179/v/1" frameBorder="0" scrolling="no" webkitAllowFullScreen mozallowfullscreen allowfullscreen></iframe>
</div><div id="Rectangle1" class="SpanningIsland ContentwoTools Ad MediumRectangle">
  <!-- /88340371/CharlotteRectangle1 -->
          <div id="div-gpt-ad-charlotterectangle1" style="" data-slot="/88340371/CharlotteRectangle1" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-charlotterectangle1');
                });
            </script>
          </div>
  
</div>








<div id="MostPopular" class="SpanningIsland ContentwoTools ">
  <div class="tabs">
    <div class="tabCurrent tab t1"><a href="#">Most Popular</a></div>
    <div class="tabBack tab t2"><a href="#">Most Shared</a></div>
    <div class="tabBack tab t3"><a href="#">Most Commented</a></div>
  </div>
  <div class="clear"></div>


  

  <div class="popularStoriesBody">
    <ul>
      
        <li class="l0 storyItem">

      
        <div class="storyTeaser">
          <a href="http://clclt.com/charlotte/grace-vanderwall-perfectly-imperfect/Content?oid=3816658">
            <img src="http://media1.fdncms.com/charlotte/imager/u/featurettecrop/3816657/review-perfectlyimperfect.jpg" alt="Grace Vanderwaal, &lt;i&gt;Perfectly Imperfect&lt;/i&gt;" class="storyImg" />
          </a>
        </div>
      


  <h4 class="headline">
      <a href="http://clclt.com/charlotte/grace-vanderwall-perfectly-imperfect/Content?oid=3816658">Grace Vanderwaal, <i>Perfectly Imperfect</i></a><a href="http://clclt.com/charlotte/grace-vanderwall-perfectly-imperfect/Content?oid=3816658#readerComments">&nbsp;<span class="commentCount">1</span></a>
    </h4>
    
      <h5 class="subhead">
        Columbia Records; Release date: Dec. 2, 2016
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Ryan Pitkin |
        
        12.14.16
      </li>
    </ul>
  </li>
      
        <li class="l0 storyItem">

      
        <div class="storyTeaser">
          <a href="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870">
              <img src="http://media1.fdncms.com/charlotte/imager/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/u/featurettecrop/2899871/music_feature2-1_35.jpg" alt="Christian punks MxPx wrestle with doubt &amp;mdash; and greatness" class="storyImg" />
            </a>
      </div>
    


  <h4 class="headline">
      <a href="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870">Christian punks MxPx wrestle with doubt &mdash; and greatness</a><a href="http://clclt.com/charlotte/christian-punks-mxpx-wrestle-with-doubt-andmdash-and-greatness/Content?oid=2899870#readerComments">&nbsp;<span class="commentCount">22</span></a>
    </h4>
    
      <h5 class="subhead">
        Mike Herrera lets his band grow beyond its beginnings
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Jordan Lawrence |
        
        10.25.12
      </li>
    </ul>
  </li>
      
        <li class="l0 storyItem">

      
        <div class="storyTeaser">
          <a href="http://clclt.com/charlotte/lara-americo-she-they/Content?oid=3816661">
            <img src="http://media2.fdncms.com/charlotte/imager/u/featurettecrop/3816660/review-she_they.jpg" alt="Lara Americo, &lt;i&gt;She/They&lt;/i&gt;" class="storyImg" />
          </a>
        </div>
      


  <h4 class="headline">
      <a href="http://clclt.com/charlotte/lara-americo-she-they/Content?oid=3816661">Lara Americo, <i>She/They</i></a>
    </h4>
    
      <h5 class="subhead">
        Independent; Release date: Nov. 17, 2016
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Ryan Pitkin |
        
        12.14.16
      </li>
    </ul>
  </li>
      
    </ul>
  </div>


  

  <div class="popularStoriesBody" style="display:none">
    <ul>
      
        <li class="l0 storyItem">

      
        <div class="storyTeaser">
          <a href="http://clclt.com/charlotte/john-cales-paris-1919-celebrates-40-years/Content?oid=3028026">
              <img src="http://media1.fdncms.com/charlotte/imager/john-cales-paris-1919-celebrates-40-years/u/featurettecrop/3028027/music_feature2-1_02.jpg" alt="John Cale&#39;s &lt;i&gt;Paris 1919&lt;/i&gt; celebrates 40 years" class="storyImg" />
            </a>
      </div>
    


  <h4 class="headline">
      <a href="http://clclt.com/charlotte/john-cales-paris-1919-celebrates-40-years/Content?oid=3028026">John Cale's <i>Paris 1919</i> celebrates 40 years</a><a href="http://clclt.com/charlotte/john-cales-paris-1919-celebrates-40-years/Content?oid=3028026#readerComments">&nbsp;<span class="commentCount">4</span></a>
    </h4>
    
      <h5 class="subhead">
        Album is a necessity for the thoughtful music listener
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Peter Gerstenzang |
        
        03.01.13
      </li>
    </ul>
  </li>
      
    </ul>
  </div>


  

  <div class="popularStoriesBody" style="display:none">
    <ul>
      
         <li class="l0 storyItem">

      
        <div class="storyTeaser">
          <a href="http://clclt.com/vibes/archives/2012/01/12/fun-police-want-to-stop-entertainment-after-midnight">
            <img src="http://media2.fdncms.com/charlotte/imager/update-fun-police-want-to-stop-entertainment-after-midnight/u/featurettecrop/2585545/1326391975-no-fun.jpg" alt="UPDATE: Fun police want to stop entertainment after midnight" class="storyImg" />
          </a>
        </div>
      


  <h4 class="headline">
      <a href="http://clclt.com/vibes/archives/2012/01/12/fun-police-want-to-stop-entertainment-after-midnight">UPDATE: Fun police want to stop entertainment after midnight</a><a href="http://clclt.com/vibes/archives/2012/01/12/fun-police-want-to-stop-entertainment-after-midnight#readerComments">&nbsp;<span class="commentCount">7</span></a>
    </h4>
    
      <h5 class="subhead">
        Bars and restaurants in residential areas would be forced to shut down entertainment.
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Jeff Hahne |
        
        01.12.12
      </li>
    </ul>
  </li>
      
         <li class="l0 storyItem">

      


  <h4 class="headline">
      <a href="http://clclt.com/charlotte/tammy-greene-the-jazz-diva/Content?oid=3551111">Tammy Greene, The Jazz Diva</a><a href="http://clclt.com/charlotte/tammy-greene-the-jazz-diva/Content?oid=3551111#readerComments">&nbsp;<span class="commentCount">2</span></a>
    </h4>
    
      <h5 class="subhead">
        She's approaching her 10th year of producing events
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Kimberly Lawson |
        
        11.05.14
      </li>
    </ul>
  </li>
      
         <li class="l0 storyItem">

      
        <div class="storyTeaser">
          <a href="http://clclt.com/charlotte/grace-vanderwall-perfectly-imperfect/Content?oid=3816658">
            <img src="http://media1.fdncms.com/charlotte/imager/u/featurettecrop/3816657/review-perfectlyimperfect.jpg" alt="Grace Vanderwaal, &lt;i&gt;Perfectly Imperfect&lt;/i&gt;" class="storyImg" />
          </a>
        </div>
      


  <h4 class="headline">
      <a href="http://clclt.com/charlotte/grace-vanderwall-perfectly-imperfect/Content?oid=3816658">Grace Vanderwaal, <i>Perfectly Imperfect</i></a><a href="http://clclt.com/charlotte/grace-vanderwall-perfectly-imperfect/Content?oid=3816658#readerComments">&nbsp;<span class="commentCount">1</span></a>
    </h4>
    
      <h5 class="subhead">
        Columbia Records; Release date: Dec. 2, 2016
      </h5>
    
    <ul>
      <li class="l1 byline">
        
          by Ryan Pitkin |
        
        12.14.16
      </li>
    </ul>
  </li>
      
    </ul>
  </div>

</div>




<script type="text/javascript"><!--
  Event.observe(document, "dom:loaded", function () {
      dnSetupTabGroup(
          $$("#MostPopular div.tabs>div"),
          $$("#MostPopular div.popularStoriesBody"),
          "tabCurrent", "tabBack"
      );

      // Deactivate links.
      $$("#MostPopular div.tabs>div a").each(function (a) {
          a.onclick = function () { return false; };
      });
  });
// --></script>
<div id="Rectangle2" class="SpanningIsland ContentwoTools Ad MediumRectangle">
  <!-- /88340371/CharlotteRectangle2 -->
          <div id="div-gpt-ad-charlotterectangle2" style="" data-slot="/88340371/CharlotteRectangle2" data-output="asynchronous" data-width="300" data-height="250">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-charlotterectangle2');
                });
            </script>
          </div>
  
</div>







    <div id="RecentComments" class="MainSidebar SpanningIsland ContentwoTools ">
      <h3><a href="http://clclt.com/charlotte/CommentArchives?feature=stories&amp;section=2124591">Recent Comments</a></h3>
      <ul class="moduleList">
  
  
  
  <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://clclt.com/charlotte/grace-vanderwall-perfectly-imperfect/Content?oid=3816658">Grace Vanderwaal, <i>Perfectly Imperfect</i></a>
      
    </h4>
       
    <ul>
      <li><p>
        
          The album just debuted at No. 9 on the Billboard 200. I love "Clay" and&hellip;
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>Samuel Silvers</strong>
      </li>
      <li class="l1">
        on December 14, 2016
        
      </li>
    </ul>
  </li>

  

  
  
  <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://clclt.com/charlotte/tammy-greene-the-jazz-diva/Content?oid=3551111">Tammy Greene, The Jazz Diva</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          Tammy Greene had not return one penny of my money or my friends for the&hellip;
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>Ripped off</strong>
      </li>
      <li class="l1">
        on November 28, 2016
        
      </li>
    </ul>
  </li>

  

  
  
  <li class="l0">
    <h4 class="headline"> Re: 
      
        <a href="http://clclt.com/charlotte/tammy-greene-the-jazz-diva/Content?oid=3551111">Tammy Greene, The Jazz Diva</a>
      
    </h4>
       
    <ul>
      <li><p>
        
          Jazz Diva cancelled an event at Biltmore and has not issued refunds as they indicated&hellip;
        
      </p></li>
      <li class="l1 byline">
        Posted by 
        <strong>Grace Robertson</strong>
      </li>
      <li class="l1">
        on November 22, 2016
        
      </li>
    </ul>
  </li>

  
  
        <li class="l0 storyItem">
          <a href="http://clclt.com/charlotte/CommentArchives?feature=stories&amp;section=2124591">More &raquo;</a>
        </li>
      </ul>
    </div>
  


      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        <div id="SkyscraperRunofSite" class="MainSidebar ContentwoTools Ad">
  <!-- /88340371/CharlotteSkyscraper1 -->
          <div id="div-gpt-ad-charlotteskyscraper1" style="" data-slot="/88340371/CharlotteSkyscraper1" data-output="asynchronous" data-width="160" data-height="600">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-charlotteskyscraper1');
                });
            </script>
          </div>
  
</div>
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      <div id="LargeLeaderboard" class="GlobalFooter ContentwoTools LargeLeaderboard Ad">
  <!-- /88340371/CharlotteLargeLB -->
          <div id="div-gpt-ad-charlottelargelb" style="" data-slot="/88340371/CharlotteLargeLB" data-output="asynchronous" data-width="970" data-height="90">
            <script type='text/javascript'>
                googletag.cmd.push(function() {
                googletag.display('div-gpt-ad-charlottelargelb');
                });
            </script>
          </div>
</div>


    <div id="FooterNavigation" class="GlobalFooter ContentwoTools ">
      <ul>
  
  
  <li class="">
    <a href="http://clclt.com/charlotte/FAQ/Page" target="_self">
      
        FAQs
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/Info/Page" target="_self">
      
        Info
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/Advertising/Page" target="_self">
      
        Advertising
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/IssueArchives" target="_self">
      
        Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/Jobs/Page" target="_self">
      
        Jobs
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/AboutUs/Page" target="_self">
      
        About Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/Events/AddEvent" target="_self">
      
        Submit a Listing
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/ContactUs/Page" target="_self">
      
        Contact Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/PrivacyPolicy/Page" target="_self">
      
        Privacy Policy
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/Staff/Page" target="_self">
      
        Staff
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://clclt.com/charlotte/Syndication" target="_self">
      
        RSS
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://vmgadvertising.com" target="_blank">
      
        National Advertising
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  



<div id="footerCopyright">
  <p>
    &copy; 2016
Womack Newspapers, Inc.<br />
    Powered by <a target="_blank" href="http://foundation.gyrobase.com/">Foundation</a>
  </p>
</div>
  <!-- Start Google Analytics code -->
  <script type="text/javascript">

    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-3016414-8']);
    _gaq.push(['_setDomainName', '.clclt.com']);
    _gaq.push(['_trackPageview']);

    (function() {
      var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
      ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
      var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
    })();

  </script>
  <!-- End Google Analytics code -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-3704224-37']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>



  <!-- Start Quantcast tag -->
  <script type="text/javascript">
  _qoptions={
  qacct:"p-f7Nas-_ZQTIUY"
  };
  </script>
  <script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
  <noscript>
  <img src="http://pixel.quantserve.com/pixel/p-f7Nas-_ZQTIUY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
  </noscript>
  <!-- End Quantcast tag -->

  <!-- Creative Loafing - Charlotte - -->
  <script type="text/javascript" defer="defer" src="http://tap-cdn.rubiconproject.com/partner/scripts/rubicon/alice.js?pc=7184/13022"></script>

  <!-- Begin comScore Tag -->
  <script>
  document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b")
  + ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));
  </script>
  <script>
  COMSCORE.beacon({
  c1:2,
  c2:"6035631",
  c3:"",
  c4:"charlotte.creativeloafing.com",
  c5:"",
  c6:"",
  c15:""
  });
  </script>
  <noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035631&c3=&c4=&c5=&c6=&c15=&cj=1" />
  </noscript>
  <!-- End comScore Tag -->


<!-- New Google Analytics Code -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-3016414-38']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- End New Google Analytics Code -->








<!-- ##### CL Charlotte Pixel ##### -->



<script type="text/javascript">
adroll_adv_id = "ZVOVNQ77GNFKZIA23DLSYC";
adroll_pix_id = "Y7AUSZECOBGM3LFYSFFHWY";
(function () {
var oldonload = window.onload;
window.onload = function(){
   __adroll_loaded=true;
   var scr = document.createElement("script");
   var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
   scr.setAttribute('async', 'true');
   scr.type = "text/javascript";
   scr.src = host + "/j/roundtrip.js";
   ((document.getElementsByTagName('head') || [null])[0] ||
    document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
   if(oldonload){oldonload()}};
}());
</script>
    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  
</div><!-- end gridCloser -->
    </body>
</html>
  

